lyteMobile - http://lytecube.com/wap/
Back
Phone Requirements

Platform: Java (J2ME)

CLDC version: 1.1, or higher

MIDP version: 2.0, or higher

JSR: JSR-75 ( File system Access)

Root Certificate: Thawte

Back